首页>教程>实用技巧>iPhone 与 iPad 最高信息安全警报 | checkm8 漏洞遭攻破

iPhone 与 iPad 最高信息安全警报 | checkm8 漏洞遭攻破

2019-11-18
1466
来源:5分彩网站

该警报适用于以下 Apple 设备的绝大多数型号,且不论其运行任何 iOS、iPadOS 系统软件:

  • ● iPhone X

  • ● iPhone 8

  • ● iPhone 8 Plusv

  • ● iPhone 7

  • ● iPhone 7 Plus

  • ● iPhone 6s

  • ● iPhone 6s Plus

  • ● iPhone 6

  • ● iPhone 6 Plus

  • ● iPhone SE

  • ● iPhone 5s

  • ● iPhone 5c

  • ● iPhone 5

  • ● iPhone 4s

  • ● iPad Pro(12.9 英寸,第 2 代)

  • ● iPad Pro(12.9 英寸,第 1 代)

  • ● iPad Pro(10.5 英寸)

  • ● iPad Pro(9.7 英寸)

  • ● iPad Air 2

  • ● iPad Air

  • ● iPad(第 7 代)

  • ● iPad(第 6 代)

  • ● iPad(第 5 代)

  • ● iPad(第 4 代)

  • ● iPad with Retina Display(第 3 代)

  • ● iPad 2

  • ● iPad mini 4

  • ● iPad mini 3

  • ● iPad mini 2

  • ● iPad mini

  • ● iPod touch(第 7 代)

  • ● iPod touch(第 6 代)

  • ● iPod touch(第 5 代)

HomePod 和 Apple Watch(Series 3 或更早版本)、Apple TV(第 3 代及更新机型)亦有可能受到影响。


问题描述:以上设备搭载了 Apple 的 A5 / A5X / A6 / A6X / A7 / A8 / A8X / A9 / A9X / A10 Fusion / A10X Fusion / A11 Bionic 以上任意一款 SoC 或 S1 / S1P / S2 / S3 以上任意一款 SiP,这些芯片或芯片组所内置的 Bootrom 含有不可修复的漏洞(因为 Bootrom 只读)。


由于 Bootrom 是设备开机时第一段载入的代码,如果其被攻破,其携带的 Apple 根证书(Apple Root CA)释放给 iBoot 以错误的授权,即可能导致上述设备遭到未经用户授权的非法篡改(越狱),其内置的安全措施 Secure Enclave 区域或内置加密区(取决于设备的新旧)将有可能获得授权而释放 AES 随机密匙,从而解密硬盘数据,它甚至可以初始化 Secure Enclave 从而为设备重新设置安全验证方式;该漏洞还可以通过删除激活实用工具程序来绕过激活锁,从而获得该恢复过固件的设备之使用权,同时仍保持设备登录 Apple ID,带来较高的信息安全风险;同时,如果入侵者继续研究此漏洞的使用方法,其最终可以对上述设备进行降级,最糟糕的是,他们甚至可以安装未经授权的系统软件。


网络锁由于依赖多方面因素,故无法直接通过该手段绕过,因为基带也是加密的。


解决办法:


● 防止设备遭到他人的接触,尤其避免链接任何不可靠的设备。因为该漏洞一定需要进入 DFU 模式,也需要电脑上的越狱工具,这强制性需要设备连接到计算机。设备锁定且开机时,未信任电脑不能入侵该手机,可以入侵的状态主要有两个:


 ◦ 已解锁且信任的情况下,设备可以通过电脑间接进入或退出此模式(当然用不到这个)

 ◦ 关机的情况下,只要特定的按键组合即可进入 DFU 模式。


只要下载 ipwndfu 和 checkra1n 两个越狱工具,就可以实施不完美越狱,完全足够窃取用户数据或者是删除激活实用工具了。不过加密的数据仍然需要用户给予开机授权,也就是那一遍逃不过的密码,否则数据仍会被加密。但在那之后,即使电脑没有被信任,设备没有被解锁,仍然能够读取未加密数据。


(如果是要绕过激活锁,目前来看需要 Mac 上的终端,但其他命令行工具可以替代。但激活锁被绕过以后,设备原 Apple ID 不会被退出,会泄露一定的用户隐私。)


● 如果不慎丢失了设备且寻回希望渺茫,则请按下「查找」中的 “抹掉 iPhone/iPad/iPod” 按钮。


● 在任何非官方途径维修设备时备份数据并抹除所有内容和设置,维修完以后再恢复。


历史上实质性的 Bootrom 漏洞只有四个,两个只能针对 A4、一个只能针对 iPhone 3GS,然而 checkm8 是 iPhone 4S 一直到 iPhone X ,发展速度也空前得快,危险级别非常高。


如果您的工作或生活需要高度保密的个人设备,那只能说这是升级所有有漏洞设备的最佳理由了。

标签: iPhone Apple A13